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ABSTRACT 

 

3D digitisation of surfaces became a standard procedure in ichnology in recent years. 3D models allow not only for the digital 
preservation of vulnerable ichnological records, but also for the illustration, qualitative description, and quantitative analysis of 
the fossils. Here we discuss how to obtain photographs for photogrammetry, to generate, scale, and orient the models, and to 
extract visualisations, measurements, and coordinates for data analysis. 
Different visualisation approaches are discussed and compared, including widely used techniques such as orthophotos, height 
maps, and contour maps, as well as rarely used yet promising methods such as low-angled shaded reliefs, surface inclination 
plots, ambient occlusion, and radiance scaling. These techniques may filter or enhance different properties of the model surface 
such as colour information, elevation, edges and slopes, 3D morphology, and specific features such as convexities or concavities, 
and will often reveal additional detail. Furthermore, an approach is presented to automatically calculate trackway parameters 
based on coordinates collected from the model visualisations. All discussed steps can be performed with free and open-source 
software, and we provide detailed software instructions. We argue that digital ichnology, when combined with sedimentological 
data of the site, can be equally or more effective and comprehensive as traditional ichnological fieldwork. 
 

Keywords: visualisation, paraview, shaded reliefs, contour plots, height maps, feature enhancement, digital ichnology 

 

RESUMO [in Portuguese] 

 

A digitalização 3D de superfícies tornou-se um procedimento padrão em icnologia em anos recentes. Os modelos 3D permitem 

não só a preservação digital de registos icnológicos vulneráveis, mas também a ilustração, descrição qualitativa, e análise 

quantitativa dos fósseis. Aqui discutimos como obter fotografias para fotogrametria, criar, medir, e orientar os modelos, e 

extrair visualizações, medidas, e coordenadas para análise de dados. 

Diferentes abordagens de visualização são discutidas e comparadas, incluindo técnicas amplamente utilizadas como ortofotos, 

mapas de altura, e mapas de contorno, assim como métodos raramente usados embora promissores, como relevos sombreados 

de baixo ângulo, projecções de inclinação de superfície, oclusão de ambiente, e escala de radiância. Estas técnicas podem filtrar 

ou melhorar diferentes propriedades da superfície do modelo como informação de cor, elevação, limites e declives, morfologia 

3D, e características específicas como convexidades ou concavidades, e revelam regularmente detalhes adicionais. Além disso, 

uma abordagem é apresentada para automaticamente calcular parâmetros de trilhos baseados em coordenadas recolhidas de 

visualizações de modelos. Todos os passos discutidos podem ser efectuados com software livre e aberto, e fornecemos 

instruções detalhadas do software. Argumentamos que a icnologia digital, quando combinada com dados sedimentológicos da 

jazida, podem ser igualmente ou ainda mais eficazes e detalhadas que trabalho de campo icnológico tradicional. 
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INTRODUCTION 

 

The use of 3D digitisation techniques in ichnology has proliferated during the last decade, and now is 

widely considered a standard procedure in the field (Falkingham et al., 2018). The benefits of these 

new set of methods can not be underestimated, and include the proper collection, dissemination, and 

long-term archiving of data that can be visualised and analysed both qualitatively and quantitatively. 

Photogrammetry, which allows to calculate 3D-models from photographs, became the most frequently 

used 3D digitisation method in ichnology (Matthews and Breithaupt, 2001; Falkingham, 2012; 

Falkingham et al., 2018). Using simple photographs as data source, it is applicable at low costs and 

allows for capturing the 3D morphology, including photo-realistic texture in high resolution. 

We here argue that 3D models of tracks and tracksites can be as effectively and comprehensively 

analysed as any traditional fieldwork would be able to, provided that they get combined with 

sedimentological data of the tracksite. The potential of 3D models in the description, illustration, and 

analysis of tracks goes beyond what was possible with traditional methods, and these new possibilities 

have not yet been fully explored and remain underused. Interpretive outline tracings are inherently 

subjective and do not capture the 3D morphology (Falkingham, 2016), while single photographs can 

be difficult to interpret even with optimal light conditions (Thulborn, 1990) and introduce perspective 

distortion. Such shortcomings can be easily overcome with 3D models, which can be projected two-

dimensionally in orthographic view (without perspective distortion) and rendered using a broad array 

of techniques that can filter or emphasize properties such as colour information, elevation, edges and 

slopes, 3D morphology, or specific features such as convexities and concavities. 

These methods frequently allow for recognizing additional footprints or shape features that are not 

easily recognisable in the field, especially when lighting is not optimal. The different projections can 

be used to digitally interpret and measure the features of interest, and to draw interpretative drawings 

and site maps. 

In the present paper, we discuss producing, visualising, and analysing 3D data of traces and tracksites. 

The process involves taking photo series of the fossil or site, model generation, model post-processing, 

visualisation, and data extraction, and is summarised in Fig. 1. We will discuss the most common 

mistakes in photographing tracks for photogrammetry, and outline how to generate, scale, and orient 

the 3D models. We then evaluate and compare different techniques for the visualisation of ichnological 

3D data, providing recommendations for the choice of methods and parameters for different types of 

structures, including high-relief and low-relief surfaces as well as skin impressions. We continue with 

discussing the extraction of data including measurements, outline drawings, sitemaps, and 

coordinates. Finally, we will present a method to automatically calculate trackway parameters based 

on coordinates taken from the models. 

Multiple software solutions exist for each of the discussed in-software steps. For the purpose of 

accessibility, we will focus on a selected combination of software, for which we provide detailed 

instructions for the in-software workflow in the appendix of this paper. This software is free and open-

source (FOSS). For the generation of 3D models we introduce Meshroom v. 2019.2 (AliceVision, 2018). 

Model post-processing and visualisation will be achieved with MeshLab v. 2020.1 (Cignoni et al., 

2008), CloudCompare v. 2.10 (CloudCompare, 2019), and ParaView v. 5.8.0 (Ayachit, 2019). 

Discussed methods for data extraction and analysis are based on the vector image editor Inkscape 

1.0 (Inkscape, 2020) and the spreadsheet application LibreOffice Calc 6.2 (The Document Foundation, 

2019). In addition, we briefly discuss the proprietary software Agisoft Metashape 1.6.0 Standard and 

Professional editions (known as Agisoft Photoscan before 2019; Agisoft, 2020), as this is the most 

widely used software for 3D model generation used in the field (AliceVision, 2018). All software 

discussed herein runs on various platforms including Linux, Windows, and, which the exception of 

Meshroom, MacOS. 
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Although we aim to cover the most frequently used 

methods in digital ichnology, the set of discussed 

methods is not exhaustive. Important areas that 

cannot be covered here include the integration of 

photogrammetry, LiDAR, and geographic 

information systems (GIS) (Breithaupt et al., 2004; 

Matthews et al., 2006, 2016; Bates et al., 2008). 

The use of archival photographs to retrospectively 

reconstruct lost tracksites is discussed in 

Falkingham et al. (2014) and Lallensack et al. 

(2015). Belvedere (2018) introduced the concept 

of stat-tracks and mediotypes, the mean or median 

3D morphology of a set of footprints, to allow for 

comparisons of morphology while suppressing 

features unrelated to trackmaker anatomy. 

Methods for the production of shape difference 

maps, which can highlight erosion of a site over 

time or differences between the mould and cast of 

a single footprint, are described in Matthews (2008) 

and Wings et al. (2016), respectively. 

 

TAKING PHOTOGRAPHS FOR 

PHOTOGRAMMETRY: COMMON MISTAKES 

 

Photographs for photogrammetry of traces and 

tracksites should adequately cover the whole object 

and have sufficient overlap, be in-focus, taken 

perpendicularly above the surface, and taken at 

different camera positions at each shot. Scale bars 

need to be placed with the object; shadows 

avoided; and surfaces cleaned. 

In the following, we list the – from our experience – most common pitfalls in acquiring quality 

photographs for photogrammetry of ichnological fossils and sites. More extensive discussions on 

photographing and model generation can be found elsewhere, for fossil footprints (Matthews, 2008; 

Matthews, Noble & Breithaupt, 2016) and body fossils (Mallison & Wings, 2014). Camera choice is 

discussed in Matthews (2008) and Mallison & Wings (2014). 

• Insufficient photograph coverage. Photographs should optimally have 2/3 overlap with each other 

if taken at a constant distance to the object. Tracksites are best photographed systematically, to 

ensure that the complete surface is covered, and sufficient overlap is present in all cases. 

Photographs at very close distances, especially when using a macro objective, may require 

increased overlap if the depth of field does not bring all areas captured by a photo into focus. 

Regions which are only visible close to the margins of the photographs may show reduced quality 

in the final model; it is therefore important that all areas of interest, especially those close to the 

edges of the model, are captured at the centres of photographs. 

• Blurry pictures. Modelling requires photographs to be well-focused and without motion and depth 

blur. For best image quality, the use of a tripod or camera stabilizer is recommended, and ISO 

should be set to a low value in the camera settings to minimize noise. Hand-held photographs may 

lead to sufficient results when enough light is present, and the object is not too close to the camera. 

Figure 1: Diagram showing the suggested workflow 
including obtaining images for photogrammetry, model 
generation (using Meshroom or Metashape), model post-
processing (using MeshLab), 2D visualisation of the 
obtained 3D data (using ParaView and CloudCompare), 
and data extraction (using Inkscape, LibreOffice Calc, 
and R). 
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Moderately higher ISO values may be necessary when taking hand-held photographs under less 

favourable conditions to reduce motion blur. When taking hand-held photographs, we recommend 

taking three independent sets of photographs, especially when the tracksite cannot be revisited 

easily, so blurry pictures can be replaced. When photographing with autofocus enabled, the 

metering mode should be set to “Centre” and the focus updated at every shot (see below for 

photographing with manual focus). When photographing small objects, and especially in Macro 

photography, the use of a tripod and mid to high f-numbers for a large depth of field is crucial. 

Small objects are often easier to capture with a small camera sensor (e.g., phone cameras) due 

to the higher depth-of-field. The depth-of-field may also be increased by using focus stacking 

(Santella & Milner, 2017). We recommend exclusion of any blurry pictures before model 

generation. 

• Oblique photographs. Vertical shots are optimal as long as overhanging parts are absent and the 

track walls are less than vertical. Low-angled photographs need to be avoided. Very small traces, 

especially when using macro photography, require both vertical and slightly angled (15–20° from 

the vertical) photographs for optimal alignment. 

• Singular camera position/pivot. The position of the camera needs to be changed with each shot. 

Avoid making photographs by pivoting the camera at a fixed position that otherwise results in a 

‘fish-eye effect’. 

• Suboptimal distance between camera and object. The resolution (and file size) of the model will 

primarily depend on the distance of the camera from the object. At closer distances, however, 

determining sufficient overlap becomes more difficult in practice because of the higher number of 

photographs required. Model resolution may be locally increased by taking pairs of photographs 

with reduced distance, to capture fine detail such as skin impressions. Changes in distance should 

not be lower than 50% (when taking close-ups) or higher than 200% (when taking overview shots) 

to ascertain continuity between shots (Matthews et al., 2016). 

• Lack of scale. As photogrammetry is scale-independent, the scale of the model needs to be set 

manually. For this reason, including one or more scale bars within the model is crucial. These scale 

bars should be large and well-readable in the centre of several photographs, respectively, but in a 

position that does not obscure important target objects.  

• Shadows. Surfaces are ideally photographed at times when no sharp shadows occur, e.g., when 

overcast or at noon, as a proper and even exposure of images is crucial. Varying lighting conditions 

and moving shadows need to be avoided. When photographs of a set are to be taken at different 

dates, it needs to be ascertained that the sun angle is consistent (Matthews et al., 2016). Although 

using compressed image formats such as JPEG are sufficient in normal circumstances when set at 

maximum quality (Mallison and Wings, 2014), RAW image formats allow for exposure adjustment 

during post-processing, potentially providing more detail in over- or underexposed areas 

(Matthews, 2008). 

• Unclean surfaces. Tracksites should be cleaned, and any water and covering vegetation removed, 

before photographing (Matthews, 2008). 

• Automatic rotation and cropping. Automatic image rotation needs to be turned off in the camera 

settings (Matthews, 2008). It is important not to crop any images. 

• Insufficient planning and lack of equipment. Depending on the specifics of the site, required 

equipment may include backup batteries and memory cards; tripods of varying heights, with 

extension arms that can be mounted horizontally for shooting down; camera stabilizers; scales; 

tape (for scale fixation); sponges (for water removal); cleaning utilities; strings (for guidance on 

a larger surface); monopods and ladders (for inclined surfaces); camera remote controls; plastic 

sheets (to diffuse sunlight), GPS units, and drones (Matthews, 2008; Mallison and Wings, 2014; 

Matthews et al., 2016). It is practical to start a series with overview shots of the tracks or tracksite 



                                                      

Lallensack et al. 2022: PHOTOGRAMMETRY IN ICHNOLOGY 

 

 

  5  ●  Journal of Paleontological Techniques  

for context, followed by at least three photographs that show each scale bar close to the centre of 

the image and in full focus. 

For highest accuracy, we recommend maintaining a constant distance between camera and object, 

and a constant zoom and focal length, especially when shooting vertical photographs (Matthews, 

2008; Matthews et al., 2016). A constant focal length can be achieved by using manual focus; 

increased care should be taken that all photographs are in focus. The automatic camera calibration of 

the photogrammetry software can be improved by adding two additional and redundant photographs 

with the camera rotated 90° and two with the camera rotated 270° (for details see Matthews, 2008; 

Matthews et al., 2016). 

 

MODEL GENERATION 

 

Model generation can be done in four principal steps: camera alignment and sparse point cloud 

generation; dense cloud generation; mesh generation; and texture generation. During the first step, 

the camera position is calculated for each photograph based on features (pixel combinations) that 

could be matched between photographs. These features, or tie points, will likewise be projected into 

3D space and form the sparse point cloud, which may already serve as a preview of the final model. 

As the second step, the dense cloud generation, is the most time consuming, it is advisable to check 

the sparse cloud and the aligned cameras (the calculated camera positions, which can be displayed 

around the sparse cloud) for obvious errors before proceeding. The meshing step reduces the dense 

cloud to a single surface of connected polygons. Although the dense cloud can be used for research 

purposes, some visualisation approaches require a meshed model (i.e., those involving shading with 

virtual light). The fourth step, the texture generation, is optional for including photorealistic colour 

information (see section “Colour information”). 

Although several software solutions for photogrammetry exist, we restrict ourselves to briefly 

introduce two solutions, Meshroom and Agisoft Metashape, which both cover the entire process of 

obtaining models from images. Meshroom is free software and easy to use but requires a CUDA 

enabled GPU (i.e., a Nvidia graphics card). The alternative, Metashape, is proprietary software and 

runs on a broader range of hardware. As photogrammetry software is currently still developed at a 

fast pace and workflows may change from one version to another, we refrain from providing detailed 

instructions on the model generation process itself, but refer the reader to the user manuals of 

Meshroom and Metashape. However, we do provide short instructions to get started with the current 

versions of both packages, and offer some advice on in-program settings specific for ichnological 

fossils, in the Appendix of this paper. 

The quality of the resulting photogrammetric model should be assessed prior to its further use. Virtual 

inspections provide a first quality check, including comparisons with photographs (Carbonneau et al., 

2003). Noise, such as small-scale spikes leading to a roughened surface, best seen under low-angled 

virtual light, or artefacts such as linear or concentric wave-like structures are a typical indicator of 

more severe error and might be confused with original features (Lallensack et al., 2015, fig. 5). A 

quantitative measure of overall model quality is the root-mean-square error (see discussion in 

Matthews, 2008). It should be noted, however, that quality may differ drastically in separate regions 

of a model and decreases towards the model edges. Metashape allows for filtering tie points based on 

their estimated errors, which may improve model quality (see Appendix for details). 

 

MODEL POST-PROCESSING 

 

The generated model requires post-processing in other software prior to 2D visualisations of the 3D 

model surface, including cropping, scaling, and orienting. Models may include colour information, 

which can be optimised after model generation. We here point to the respective functions in MeshLab 
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(see Appendix for detailed instructions) but note that most steps can be alternatively achieved in 

CloudCompare or Metashape. 

 

Cropping 

Noisy surroundings of models and slab edges or other regions that are not of interest should be 

cropped away. This can reduce model relief and facilitate the generation of graphical output. Various 

cropping tools are available in MeshLab, including the “Select Faces in a rectangular region” tool and 

the more flexible “Select Faces/Vertices inside polyline area” tool. Both tools can select the area of 

interest and invert the selection, after which all surrounding areas can be deleted. Models may contain 

smaller parts disconnected from the main object, which can be automatically selected and deleted, 

e.g., in MeshLab using the “Remove isolated pieces (wrt Diameter)” filter. 

 

Scaling 

Photogrammetry is scale-independent, meaning that the size of the model has to be set to allow for 

measurements. Defining the scale of the model can be done in MeshLab, provided that at least one 

object of known length is present within the model. First, this object (e.g., a scale bar) is to be 

measured using the “Measuring” tool. This measurement is used to calculate the scale factor (actual 

length/length given by the “Measuring” tool). The model can then be scaled according to this factor 

using the “Transform: Scale, Normalize” filter. Accuracy can be enhanced, and error quantified, by 

calculating several scale factors based on additional scale bars, preferably placed on opposite sides of 

the object, and taking the mean of these scale factors. 

Metashape Professional offers marker-based scaling, where at least two marker points are placed on 

the object of known length directly in the input photographs. This method is generally more accurate 

than defining the scale on the model itself. Markers for scaling may be detected automatically when 

using coded targets. 

 

Figure 2: Contrast limited adaptive histogram equalisation (CLAHE); left: original photograph of theropod tracks on display 

at the Royal Tyrrell Museum of Palaeontology, Drumheller, Alberta; right: same photograph processed with CLAHE. Note 
that bright and dark regions were modulated. 
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Model orientation 

2D visualisations of tracks should be in precise top view, allowing shape comparisons and 

measurements, although additional inclusion of oblique views can be helpful to improve depth 

perception (Falkingham et al., 2018). Where overhangs obscure track morphology, the model can also 

be shown in bottom view by switching the z-axis. 

To achieve a precise model orientation, the plane spanned by two of the three axes (the x and y-axes) 

should be identical to the surface plane of the model (henceforth termed the horizontal plane). Manual 

adjustment of the model to the desired orientation is inaccurate and can be avoided. Automatic fitting 

to the horizontal (xy) plane can be easily done in MeshLab using the “Transform: Rotate to fit to a 

plane” filter (the alternative “Transform: Align to Principal Axes” filter should be avoided as it can lead 

to mirroring of the model). Before applying the filter, the model needs to be selected. It is possible to 

select only parts of the model that will then serve as a reference for the horizontal plane to exclude 

areas of high relief from the fitting process. Per default, the filter will also centre the model on the 

origin of the coordinate system. After fitting to the horizontal plane, the model can be rotated around 

the z-axis into the desired orientation (e.g., to have digit impressions facing upwards) using the 

“Transform: Rotate” function. Model orientation can be checked by examining the orientation axes 

Figure 3: Different graphical representations of Rhynchosauroides footprint NML-G 2022/0001 from Bernburg, Germany 
(collection Frank Trostheide, Naturkundemuseum Leipzig), with very low relief but well-preserved skin impressions. All plots 
except for (F) generated with ParaView. A: Orthophoto, enhanced with CLAHE, without oblique light shading. B: Greyscale 
heightmap, without oblique light shading. C: The plot of B processed with CLAHE. Note that individual scales are better 
visible, but that shades of grey do not correspond to specific heights anymore. D: Heightmap blue-to-red with virtual low-
angled light shading. E: Shaded relief, virtual light source from the top left. F: Radiance scaling plot, enhancing the 
appearance of scale impressions. To scale. Colour legends in cm. Arrows indicate direction of low-angled light. 
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(the “Show Axis” function of MeshLab). If the “Front” view displays the underside of the model rather 

than the upper side, the model needs to be rotated around the x or y-axis by 180°. 

 

File export and texture 

The most commonly used formats to distribute photogrammetric 3D data include the Stanford Polygon 

File Format (ply) and Wafefront OBJ (.obj). Both formats support the inclusion of colour information 

(see below). 

An important advantage of photogrammetric models over other 3D digitisation methods is the 

inclusion of colour information. A single colour value can be associated with each vertex of the model. 

When using the OBJ or PLY formats, these vertex colours can be directly stored within the model. With 

vertex colours, however, the resolution of the colour information is limited to the resolution of the 

mesh. Much higher resolutions can be achieved by calculating a photo- realistic texture, which can be 

done with both Meshroom and Metashape. When exporting with texture included, the model file will 

be accompanied by one or more additional texture files (usually JPEG). When exporting to the obj 

format, there will be a mtl file in addition to the model and texture files. Textures can be used instead 

of or in addition to vertex colours. To ensure that different software solutions can load the texture, 

the model file name should avoid spaces. 

 

2D VISAULISATION 

 

3D data of trace fossils can be visualised using a variety of methods, including orthophotos; shaded 

reliefs; height maps; contour plots; ambient occlusion; radiance scaling; and cross- sections. In the 

following, we introduce each of these methods and discuss their utility for enhancing different features 

of interest. For the generation of the different 2D visualisations, we recommend three free software 

solutions: MeshLab, ParaView, and CloudCompare. 

MeshLab is well-suited as a quick and performant viewer of 3D models, while ParaView and 

CloudCompare allow for a broader array of graphical outputs. All three software solutions allow for 

exporting high-resolution visualisations. Detailed instructions for the creation of these graphical 

outputs are provided in the Appendix. Respective options in Metashape Professional are mentioned 

when present; we refer the reader to the Metashape Manual (Agisoft 2020b) for detailed instructions.  

 

Perspective vs. Orthographic view 

Per default, the discussed 3D software will correct for perspective, so that any screenshots taken from 

the model are affected by perspective distortion – as is the case with photographs. Alternatively, 3D 

models can be displayed in orthographic projection, where the projection lines are parallel to each 

other. Orthographic projections are projected as maps, i.e., the scale is uniform across the image. We 

recommend using orthographic projections, especially when the depicted track is shown in top view. 

Orthographic projections allow for precise comparisons of separate models and allow for taking 

measurements directly from these 2D- representations. The discussed 3D software allows for toggling 

between perspective and orthographic mode. In ParaView, the equivalent option is termed “Camera 

parallel projection”. 

 

Colour information and CLAHE 

Increasing contrast often makes additional detail visible. Vertex colours of a model can be adjusted 

for contrast, brightness and gamma in MeshLab, while separate texture files and 2D visualisations can 

be directly manipulated using standard image editors such as GIMP (www.gimp.org). However, 
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contrast increase, whether manually or automatically using histogram equalisation, often results in 

over- or underexposure of separate parts of the image. This problem can be avoided using Contrast 

limited adaptive histogram equalisation (CLAHE, see Zuiderveld, 1994), which calculates separate 

histograms for different sections of the image, therefore achieving uniform contrast and brightness 

even when the source image is unevenly exposed to light (Fig. 2). 

CLAHE can be applied to standard photographs (Fig. 2), texture files, and 2D visualisations such as 

orthophotos (Fig. 3A). It may also enhance detail in height maps, especially when features of low 

relief (e.g., individual tracks of a tracksite or skin impressions) are distributed over an uneven surface 

(Fig. 4C). It has to be noted, however, that absolute elevation cannot be interpreted from such 

modified height maps anymore. A plugin for the free image processing program ImageJ (imagej.net) 

is available (Saalfeld, 2009; see https://imagej.net/Enhance_Local_Contrast_(CLAHE)). Important 

parameters include the “block size”, the size of the separate image sections to be adjusted, and the 

“max slope”, which defines the intensity of the adjustment. The effect of the CLAHE plugin can be 

lessened by increasing “block size” and reducing “max slope”, respectively. 

 

Orthophotos 

Orthophotos are geometrically corrected (orthorectified) photographs of an area in top view (Fig. 3A, 

4A). They can be extracted from 3D models using MeshLab or ParaView, provided that texture files 

were included with the model, or calculated directly from the aligned images using Metashape. In 

MeshLab and ParaView, the default textured model view will also include shading according to a virtual 

light source and, if present, vertex colours. To generate a pure orthophoto without additional oblique 

light shading, the virtual light source (ParaView) or vertex colours and model shading (MeshLab) have 

to be disabled. 

 

Height maps 

Height maps, also referred to as “depth-colour maps”, are colour-coded elevation plots that allow for 

the effective illustration of the depth profile of a surface model. In many cases, height maps convey 

the 3D morphology of tracks more clearly and detailed than simple photographs, and may even 

highlight features that are difficult to see in the field. Height maps can be generated using ParaView, 

CloudCompare, or Metashape Professional. 

ParaView and CloudCompare provide a selection of colour scales (i.e., the selection and number of 

separate colours to be used), and furthermore allow to import custom-made ones. As cool colours are 

generally interpreted as depths and warm colours as heights, the colour scale of choice should reflect 

this rule. The optimal colour scale to use depends on the respective model. Simple colour scales with 

few colours, such as the default colour scale of ParaView (“Cool to Warm”; blue-white-red), work well 

with most models and are easy to interpret, although the low amount of colours may not sufficiently 

differentiate between subtle changes in relief, so that details may get lost or are difficult to see from 

the height map. On the other hand, colour scales with more colours will show more detail, but are 

often more difficult to interpret especially when the relief of the tracks is smaller than the relief of the 

surrounding surface. In the latter case, separate footprints and regions of the surface may appear in 

different colours, making visual comparisons of these footprints and areas difficult. An example of a 

colour scale with many colours that has been tested in previous studies is the “Rainbow Desaturated” 

preset of ParaView, which includes eight distinct colours (Fig. 4B). As an alternative, the greyscale 

preset running from white to black (or vice versa) can be used (Fig. 3B). This preset is especially 

advantageous in cases where the resulting figure cannot be printed in colour. As is the case with colour 

scales that include few distinct colours, however, details of the relief may get lost. 
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Per default, the colour scale will include the entire depth of the model. It may, therefore, be necessary 

to tight-crop the model to remove surroundings such as slab borders to decrease the total relief, so 

that the objects of interest (i.e., the trace fossils) are better differentiated (see above for cropping 

methods). Alternatively, or additionally, the highest and/or lowest portions of the model may be filled 

with uniform colour. The colour distribution can also be adjusted manually to concentrate more colours 

within the height interval of interest, possibly improving the visibility of the details of interest. 

Both ParaView and CloudCompare combine the height map with shading according to a virtual light 

source per default. While both software solutions allow for adjusting the position of this light source, 

ParaView allows for adjusting the intensity and warmth. Adjusting these values can improve the 

visibility of subtle surface features; especially the option to lower the light source to produce low-

angled light can be advantageous (Fig. 3D; see section “shaded reliefs” below). When fine surface 

detail is not of interest, the oblique light shading can be disabled, resulting in a clearer visualisation 

of larger relief features (Fig. 3B, 4B). Disabling oblique light shading to achieve consistent illumination 

of edges is especially important when the margins of shape features (i.e., their dimensions and shape) 

need to be visualised accurately. 

A height map requires both a regular scale and a colour legend that indicates the heights, associated 

with the colours. Colour legends can be displayed by both ParaView and CloudCompare. 

Figure 4: Natural cast of T3/18, footprint of a large theropod trackway from Münchehagen, Germany (Lallensack et al., 
2016). A: Orthophoto combined with oblique light shading. B: Heightmap of multiple colours (rainbow) without oblique light 
shading. C: Height map (blue-to- red) combined with contour lines (n=30) and oblique light shading. D: High number of 
contours (n=50) to highlight surface steepness. E: Inclination plot highlighting steepness combined with oblique light 

shading. F: Ambient occlusion plot enhancing surface detail. To scale. Colour legends in cm. 
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Contour plots 

Contour plots, consisting of lines of equal elevation, are a common way of displaying three- 

dimensional topography in two dimensions, especially single footprints. The contour interval can either 

be relative to the total height of the model (using a fixed number of contours) or absolute (e.g., fixed 

intervals of 0.5 cm). Relative contour intervals come with the advantage that the same number of 

contours can be used for footprints of different sizes. This allows for comparing and measuring specific 

contours between specimens. Contour plots can be generated with ParaView using the “Contour” 

function and with CloudCompare using the “Rasterize” tool (see Appendix for instructions). Contour 

plots can also be created with Metashape Professional. 

Attributes that frequently need to be adjusted are the colour and line thickness. With both ParaView 

and CloudCompare, it is possible to colour the individual contours by height using the selected colour 

scale. A contour plot may be combined with any of the other graphical representations that may be 

created with ParaView or CloudCompare. A common approach is to combine contour plots with height 

maps. Combining separate contour plots allows for different formats (e.g., to highlight each fifth 

contour using a different colour and line width). 

 

Shaded reliefs 

Shaded reliefs make use of an virtual light source 

positioned at an oblique angle to the model 

surface to emphasize the steepness of the 

topography. Such shading is often used in 

combination with other forms of visualisation, 

such as height maps (Fig. 3D; 4C) and 

orthophotos (Fig. 4A). However, when the relief of 

the model is low, shaded reliefs are most effective 

in enhancing subtle surface detail when used with 

any colour information disabled and with the 

virtual light at a very low angle (Fig. 3E, 5B). As 

the digital counterpart to the respective method in 

real-world photography, shaded reliefs are 

intuitive to use, and suitable for greyscale figures. 

The optimal position of the light source depends 

on the respective surface features that shall be 

enhanced. Low-relief surfaces generally work best 

with a very low position of the light source, while 

higher reliefs require higher light source positions. 

Lighting from the upper left is the standard used 

for scientific illustrations, and therefore most easy 

to interpret by the human eye. Other light source positions may be required to highlight surface details 

of interest (e.g., claw impressions), depending on the orientation of these structures (Fig. 5). 

Light from the bottom, however, may cause concavities to appear as convexities and vice versa (Fig. 

5B). MeshLab, ParaView, and CloudCompare allow for moving the light source interactively. 

 

Surface inclination plots 

It is possible to shade the mesh surface according to its inclination relative to the horizontal plane 

(i.e., the orientation of the vertex normals relative to the z-axis). In such plots, white indicates a more 

horizontal, and black a more vertical surface. With this technique, the slopes of the surface can be 

Figure 5: Sauropod trackway from the Late Triassic of 
Greenland (Lallensack et al., 2017). A: Orthophoto. B: 
Shaded relief, with the virtual light set from below to 
highlight pedal claw impressions; note that the footprints 
may be perceived as convex hyporeliefs due to the position 
of the light source (light direction indicated by arrow). 
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effectively enhanced (Fig. 4E). This may also help 

with detecting and tracing the steepest slopes 

along the footprint margin for measurements and 

interpretive outlines; as the slopes can be 

displayed with high contrast, such plots may 

furthermore serve as objective replacements for 

interpretive outline drawings. Inclination plots can 

be easily created with ParaView by setting the 

mesh colouring to “Normals”, restricting the range 

of the colour scale to increase contrast, and by 

choosing a black-to-white scale. The use of colour 

scales is possible but only greyscales will provide 

the illusion of virtual lighting and are easy to 

interpret by the human eye. Similar plots may also 

be achieved by using a very high number of 

contours lines. 

Inclination plots appear similar to a shaded relief, 

but without depending on the lighting. This is an 

advantage when the relief of the surface is more 

pronounced, as it is often the case with a single 

footprint. With low-relief surfaces, in contrast, 

enhancement of surface noise may obscure the 

features of interest and directed light (shaded 

reliefs) is the more appropriate method to use. 

It is possible to choose the x or y-axis instead of the z-axis. In this case, the resulting plot can be 

largely equivalent to a shaded relief, with the perceived lighting being parallel to the selected axis, 

and the perceived angle of lighting determined by the narrowness of the colour scale. Such inclination 

plots can, therefore, be a quick way to produce shaded reliefs, enhancing detail on low-relief surfaces. 

 

Ambient occlusion 

In ambient occlusion (Zhukov et al., 1998), each point of the surface is shaded according to its 

exposure to ambient lighting, i.e. the portion of “sky” visible from the respective point. More exposed 

parts of the surface (e.g., at the top of a projection) will appear brighter, while more occluded parts 

(e.g., adjacent to a projection) will appear darker. Ambient occlusion is used to effectively enhance 

surface detail, and improve the perception of 3D morphologies (Fig. 4F). For surfaces with higher 

relief, surface detail may appear clearer than with any of the other methods presented herein. The 

method is, however, not suitable for low-relief models. It has been, to our knowledge, first applied to 

ichnofossils by Ahn et al. (2010). Ambient occlusion plots can be generated with MeshLab, 

CloudCompare, and Metashape Professional. 

 

Radiance scaling 

The visualisation of 3D models is an active field of research, and additional, more elaborated methods 

that enhance the appearance of surface features selectively based on size and morphology have been 

published. Amongst these promising techniques is radiance scaling (Vergne et al., 2010), which uses 

the intensity of reflected light to improve the distinction between convex and concave surface features 

of a specified size. This method may be used to detect and characterise shallow impressions, such as 

very faint footprints or skin impressions, and may provide detail not readily visible otherwise (Fig. 3F). 

Radiance scaling has been implemented in MeshLab, but this implementation does not allow for setting 

Figure 6: Obtaining cross profiles. Top: Orthophoto of a 
3D model of a Synaptichnium track from Berndorf, 
Germany (SKF UMBD 138, Collection H. Klein, Saurierwelt 
Paläontologisches Museum, Neumarkt, Germany; see 
Klein and Lucas, 2017) showing skin impressions, with the 
red line indicating the extracted profile. Bottom: Elevation 
profile of the three subsequent tubercle impressions. 
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the scale of the features to be detected and is therefore of limited use for visualising ichnofossils. Full 

functionality is provided by the free research software Gratin (Vergne and Barla, 2015), for which a 

ready-made pipeline is provided in the supplementary information of this paper, with detailed 

instructions given in the appendix. 

 

Cross sections 

Cross sections, i.e., height differences along a pre-defined line on the model surface, may be helpful 

to study relief structures such as skin impressions. By simplifying the three- dimensional structure to 

a two-dimensional line, cross sections can illustrate the precise shape of structures (Fig. 6); their xy-

coordinates can also be exported to quantify and analyse these shapes. Cross sections can be 

produced with the “Extract Sections / Unfold” tool of CloudCompare, as well as with Metashape 

Professional. 

 

DATA EXTRACTION 

 

Measurements and line drawings 

Provided that the model is scaled (see “Scaling” 

above), it can be used for detailed measurements. 

The discussed software all provide tools that allow 

for measuring in 3D directly on the model, and are 

useful for any measurements that are not 

necessarily parallel to the horizontal plane of the 

model. In the majority of cases, however, 

measurements need to be taken parallel to the 

horizontal plane, and accidental deviations of the 

measured line from the horizontal plane may 

result in significant error. These deviations are 

difficult to avoid as the starting and end points of 

the measured line have to be placed on the three-

dimensional mesh surface, making it necessary to 

set the z value to equal values after defining the 

line. 

We here recommend taking measurements from 

exported 2D-visualisations of the model in an 

external software such as Inkscape. This 

effectively prohibits measurements in a plane 

other than the horizontal plane, and offers more 

flexibility and additional functions such as angular 

measurements and helper lines. In Inkscape, 

measurements can be done using the 

“Measurement tool” (see detailed instructions in 

the appendix). 

We recommend the use of vector graphic editors such as Inkscape for producing interpretive tracings 

of footprints, trackways, and whole tracksites. It is possible to consider multiple 2D visualisations 

together by placing each visualisation on a separate layer in the vector editor. The different 

visualisations can then be aligned on top of each other into an image stack. The tracing itself is done 

on an additional transparent top layer, and the visualisations of the lower layers can be easily switched 

on and off for reference while drawing. 

Figure 7: Sequential 2D-coordinates (five per footprint) 
extracted using Inkscape for the automatic calculation of 
trackway parameters with the “Trackway Calculator” 
spreadsheet. The trackway reference points (“Z”) are 
shown in blue. A: Sauropod trackway S1 from the Late 
Triassic of Greenland (Lallensack et al., 2017), with 
individual coordinate points labeled, and trackway 
reference points coinciding with the intersection of the 
lines defining the footprint length and width. B: 
Diadectomorph trackway (Ichniotherium cottae) from 
Birkheide, Germany (Buchwitz and Voigt, 2018), showing 
the use of fitted templates for accurate coordinate 
extraction according to the footprint rotation. Trackway 
reference points are defined as the basis of digit impression 
III. Note that the reference coordinate cannot be placed 
for footprint RP1 given the incomplete digit impression III, 

and is moved to the right to be automatically excluded by 
the calculation spreadsheet. 
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Automated calculation of trackway parameters based on xy-coordinates 

If a large number of measurements is needed, especially multiple parameters of trackways, it can be 

efficient to collect xy-coordinates from which linear and angular measurements can be automatically 

calculated afterwards (Lallensack et al., 2019). Our aim is to make these methods as accessible as 

possible by providing a detailed procedure in the appendix, and the spreadsheet “trackway calculator” 

for the automated calculation of a broad array of parameters of quadrupedal trackways in the 

supplementary material. 

2D coordinates are here collected using Inkscape, although different software solutions (such as 

ImageJ) may be used alternatively. Coordinate export in Inkscape requires the installation of the 

plugin “ExportXY” that is also provided in the supplementary information of this paper. 2D coordinates 

may be collected from interpretive outline drawings or 2D-visualisations of the 3D model. The 

“trackway calculator” sheet expects five coordinates per footprint (Fig. 7), which have to be placed in 

the following order: L1 and L2 mark the posterior and anterior end of the trackway midline, 

respectively, and capture footprint length and rotation. W1 and W2 are the medial and lateral points 

of a line perpendicular to the trackway midline, and capture footprint width. The last coordinate, Z, is 

the reference point used for the calculation of distances between footprints (such as pace and stride 

length). Z can simply be the intersection between the L1-L2 and W1-W2 lines, but other definitions 

(e.g., the tip of one of the digit impressions) may be chosen. 

Besides the coordinates, the “trackway calculator” sheet accepts additional data: The ID is a unique 

identification name or number of the trackway. The scale can be easily added by extracting the 

coordinates of the beginning and end of the scale bar in Inkscape. The “Hip- height – Pes length ratio” 

is required for calculations of absolute locomotion speed; e.g., a value of “4” is a commonly assumed 

(Alexander, 1976). The optional “Cardinal direction” field accepts coordinates of a line capturing the 

south-to-north direction. 

The output for each individual footprint can be found when scrolling to the right in the first sheet. A 

summary is presented in the second sheet and includes the average, median, standard variation, 

coefficient of variation, minimum, and maximum of different parameters; the mean configuration and 

the standardised mean configuration; and statistical tests for selected pairs of measurements (t-tests 

for the equality of means and f-tests for the equality of variances). Parameters per step cycle can be 

found on the third sheet. Trackway parameters are calculated using both standard trigonometric 

functions and vectors. Footprint rotation angles are calculated based on the preceding, following, and 

opposite stride for maximum accuracy. 

 

3D data extraction for analysis in R 

Methods for data extraction described above are limited to interpretive tracings, which are partly 

subjective (Falkingham, 2016), or single measurements, which may not capture the complete shape. 

Contour lines provide a natural basis for more comprehensive shape analyses of footprints. ParaView 

allows for exporting point coordinates of contour plots (“Filters” > “Integrate Variables”); these 

coordinates are however difficult to use as they are neither ordered nor sorted by contour. 

Alternatively, 3D models may be directly imported into the free statistical computing environment R 

(R Core Team, 2019) using the vcgImport function of the Rvcg package (Schlager, 2017), which 

supports a number of common formats including PLY. Contour lines may be extracted from the 

imported model using the “getContourLines” function of the contoureR R package (Hamilton, 2015). 

Methods for processing these contours for ichnological studies were presented by Lallensack (2019), 

including their sorting, resampling, filtering, and homologisation as well as the automatic derivation 

of outlines, landmarks, and measurements. 
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CONCLUSIONS 

 

A comprehensive methodology is presented to produce, process, and analyse three- dimensional 

surface models for ichnological research using free and open-source software. We note that the 

production of quality photogrammetric models is not trivial, and review the most common mistakes 

in obtaining pictures. The presented methods for data extraction require accurate model scaling, 

automatic fitting to the horizontal plane, and orthographic projection. 3D models allow for 2D 

visualisations such as orthophotos, height maps, shaded reliefs, contour plots, inclination plots, 

ambient occlusion, and radiance scaling, which can effectively enhance different aspects of the 3D 

morphology and provide a broader scope than traditional visualisation techniques such as 

photographs. The different visualisation techniques are compared, and recommendations on method 

choice for different purposes and types of data given. We provide a method for the automatic 

calculation of trackway parameters based on xy-coordinates collected from 2D visualisations of the 

models. It is argued that, in many cases, the discussed approaches have the potential to replace 

respective traditional approaches that previously had to be carried out in the field. 

 

SUPPLEMENTARY MATERIAL 

 

The trackway calculator spreadsheet, the ExportXY-plugin for Inkscape, and example files are 

available at: 

https://doi.org/10.6084/m9.figshare.11739897.v1  

 

A Gratin pipeline for radiance scaling by Romain Vergne is available at: 

https://doi.org/10.6084/m9.figshare.12251966.v2  
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APPENDIX. SOFTWARE INSTRUCTIONS 

 
 

ON-LINE TUTORIALS 

 

ParaView tutorial videos illustrating methods discussed in this paper by Jens N. Lallensack: 

https://www.youtube.com/playlist?list=PLj3Ekg0ZUJ-JCSvE4W53Ihe282N9vUOfZ 

 

Collection of photogrammetry tutorials by Heinrich Mallison: Dinosaurpalaeo 

https://dinosaurpalaeo.wordpress.com/  

 

Collection of photogrammetry tutorials by Peter Falkingham: 

https://peterfalkingham.com/blog/  

 

Collection of MeshLab introductory videos: Mister P. MeshLab Tutorials 

https://www.youtube.com/playlist?list=PL8B1E816EAE236B4D 

 

ON-LINE TUTORIALS 

 

Meshroom 

In Meshroom, images first need to be added to the “Images” pane (using drag&drop), after which the 

different steps (displayed as “nodes” in the “Graph Editor” pane) can be run automatically with default 

values by pressing the “Start” button. Results can be viewed in the “3D Viewer” pane by double-

clicking on the respective item in the “Graph Editor” (e.g., “MeshFiltering” for the basic mesh). Results, 

including .obj files, from all nodes will be automatically exported to the folder where the project was 

saved. While the default options lead to decent results in many cases, processing parameters may be 

changed using the “Graph Editor”. Model processing may fail if minimum requirements of the default 

settings on hardware resources and image quality and quantity are not met. 

 

Metashape 

In Metashape, the model is run by adding photos using the “add photos” icon of the “Workspace” 

pane, and calling the four principal steps in succession from the “Workflow” menu. As in Meshroom, 

the alignment accuracy may be set to “high” or even “highest” for best quality in the “Align Photos” 

step. In case the alignment is inaccurate, it can help to disable the “generic preselection” option and/or 

to drastically increase the “tie points” and “key points” in the “Align Photos…” dialog. 

To reduce noise in the final model, it is advisable to remove less accurate points from the sparse cloud 

before continuing with dense model generation. This can be done using the “gradual selection” function 

available from the “Model” menu, where the “reconstruction uncertainty” filter, used with a threshold 

of “10”, is especially effective. The points selected by the filter should then be deleted, and the 

alignment optimised by calling “Tools” > “Optimize cameras”, checking “Adaptive camera model 

https://www.youtube.com/playlist?list=PLj3Ekg0ZUJ-JCSvE4W53Ihe282N9vUOfZ
https://dinosaurpalaeo.wordpress.com/
https://peterfalkingham.com/blog/
https://www.youtube.com/playlist?list=PL8B1E816EAE236B4D
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fitting”. We furthermore recommend to set the “depth filtering” option of the “Build dense cloud…” 

dialog to “aggressive”. This may result in the loss out very small-scale differences in relief, which, 

however, in the case of ichnological fossils are much more likely to represent noise than actual 

features. 

 

MODEL POST-PROCESSING 

 

The three post-processing steps (cropping, scaling, and orienting) can be done in MeshLab. Note that 

in MeshLab the model must be exported to save the changes (“File” > “Export Mesh”). To allow for 

generating surface inclination plots in ParaView (see below), the “Normal” option needs to be activated 

in the “Choose Saving Options” dialogue that will appear when attempting to save a model in MeshLab 

 

Cropping 

• “Select Faces in a rectangular region” tool, available from the toolbar: Selections can be inverted 

by pressing the “i” key, and deleted using the “Delete the current set of selected faces and all the 

vertices surrounded by that faces” key, which is the rightmost button of the tool bar. Simply hitting 

the “del” or “delete” key will only remove the faces but not the vertex points. 

• “ Select Faces/Vertices inside polyline area” tool. As above; it has to be ascertained that “Faces 

Selection” (not “Vertices Selection”) is active (see instructions in the red window that will appear 

in the upper left of the screen after calling the tool). 

• “Remove isolated pieces (wrt Diameter)” filter, available in “Filters” > “Cleaning and repairing”: A 

value of, e.g., “50” in the “perc on” field in the filter dialog removes all disconnected parts that are 

smaller than 50% of the diameter of the model. 

 

Scaling 

• Scale Factor calculation: The “Measurement tool” to measure the object of known length (e.g., the 

scale bar included in the model) is available from the toolbar. For example, if the scale is 20 cm in 

reality, and the “Measuring” tool indicates that it is “2 m (MO: 2)”, the scale factor is 0.2/2 = 0.1. 

• “Transform: Scale, Normalize” filter for scaling according to the scale factor, available in “Filters” 

> “Normals, Curvatures and Orientation”. The scale factor can be entered in the “X Axis” field (the 

options “Freeze Matrix” and “Uniform Scaling” need to remain set), after which the scale can be 

applied to the model. The model may disappear from view after this step; calling “Windows” > 

“View from” > “Front” will centre it again. 

 

Fitting of the horizontal (xy) plane and orientation 

• Model selection: use, e.g., the “Select Faces in a rectangular region” tool, which is available from 

the toolbar. A rectangle has to be drawn either around the whole model or a part of it that shall 

serve to define the horizontal plane. The selection will then appear in red. 

• Apply the “Transform: Rotate to fit to a plane” filter (“Filters” > “Normals, Curvatures and 

Orientation”), left at default options. Make sure the “Move to Origin” option is set so that the fitted 

model will be centred. After applying the filter, apply “Filters” > “Selection” > “Select None” to 
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undue the selection. The fitted model can be viewed in top view (along the z-axis) by applying 

“Windows” - “View from” -> “Front”. 

• Activate the “Manipulators Tool” (available from the toolbar) to rotate the model around the z-

axis. Press the “R” key to enable rotation, the “Z” key to select the z-axis, and the “Space” key to 

enable rotation around the centre of the model. Rotation can then be done interactively with left 

click + drag. To accept the changes press the “enter” (pc) or “return” (mac) key, and reject 

changes with the “del” (pc) or “delete” (mac) key. Before exporting the model, the matrix needs 

to be freezed (“Filters” > “Mesh Layer” > “Matrix: Freeze current matrix”). 

• If the model is flipped upside-down, it is easiest to use the “Transform: Rotate” filter (“Filters” > 

“Normals, Curvatures and Orientation”). In the filter dialog, rotation on “X axis” or “Y axis” should 

be selected and an angle of 180° specified. 

 

2D VISUALIZATION 

 

Model import and texture activation 

• In MeshLab, a model can be opened by calling “File” > “Import Mesh…”, or simply by dragging the 

model file into the program window. The texture, if available, will be loaded automatically. It can 

be disabled by setting “Texture Coord” to “Off” in the “Layer dialogue” (“View” > “Show layer 

dialogue”; opened by default). 

• In ParaView, a model can be opened using the “File” > “Open…” dialogue (or by dragging the 

model file into the program window), and by pressing the “Apply” button of the “Properties” pane 

(“View” > “Properties”; opened by default). If needed, the orientation of the model can be 

corrected using the “set view direction” buttons available from the toolbar (the -Z button will set 

the model to top view if the model was correctly oriented with MeshLab as explained above). 

• The texture is not loaded automatically in ParaView. The texture file (which can be, e.g., a jpg) 

can be selected and loaded using the “Texture” option in the “Lighting” section of the “Properties” 

pane. This section will only be visible after toggling the “advanced properties” using the gear icon 

in the upper right of the “Properties” pane. 

 

File export 

• In MeshLab, the 2D visualisation currently visible on the screen can be exported using the “Save 

snapshot” feature (available from the toolbar). Resolution of the output file can be improved by 

increasing the “Screen Multiplier” setting. Before image export, distracting control elements such 

as the track ball and the info panel can be disabled using the “View” menu. The background may 

be changed/disabled with the “Background” option of the “Save snapshot” dialogue. 

• In Paraview, the graphical output can be exported by selecting “File” > “Save Screenshot…” from 

the menu. Resolution of the output file can be adjusted in the “Image Resolution” option of the 

“Save Screenshot Options” dialogue; the “x” button allows to quickly double the requested 

resolution. Note that text and lines, including the scale bar, background grid, and contours (but 

not the colour legend), will not be scaled proportionally; it is therefore necessary to increase their 

width and size manually before screenshooting by the same factor with which the “Image 

Resolution” values are to be increased. 



                                                      

 Lallensack et al. 2022: PHOTOGRAMMETRY IN ICHNOLOGY -  APPENDIX  

 

 

  Appendix 4  ●  Journal of Paleontological Techniques  

• The background may be changed/disabled using the “Override colour Palette” option of the same 

dialogue. 

• In CloudCompare, 2D visualisations are exported by calling “Display” > “Render to File”. To change 

the background to white, and the text and scale bar to black, go to “Display” > “Display options: 

colours and Materials: Colours” and select and change the “background” and “text” entries 

accordingly. 

 

Scale bars and background grids 

• In MeshLab, a background grid for scale can be added by using the “Render” > “Background Grid” 

option. After calling this option, a new entry (“Background Grid”) will appear in the “Layer 

Dialogue” , where the “Box Ratio” may be set to “1”, and the “Major” and “Minor Spacing” (defining 

the size of the grid squares) adjusted as needed. 

• In ParaView, a background grid can be added by checking the “Axes Grid” entry in the 

“Annotations” section of the “Properties” pane (available only after toggling the “advanced 

properties” as described above). 

• In ParaView, a scale bar can be added using the “Ruler” function (“Sources” > “Measurement tools” 

> “Ruler”; press “Apply” in the “Properties” pane to load). In the “Properties” pane, the “Show 

Line” checkbox in the “Distance” section should be unchecked. Per default, the scale bar is centred 

on the model and 1 m in length (-0.5 to 0.5). To adjust position and length, the values for “Point1” 

and “Point2” (x, y, and z, respectively) in the “Distance” section of the “Properties” pane can be 

changed (e.g., values of “0”, “-1”, “0” for “Point1” and “0.1”, “-1” , “0” for “Point2” will set the 

scale bar to 0.1 m and move it 1 m towards the bottom of the plot). The unit can be added to the 

scale legend using the “Label Format” option in the “Label Properties” section by adding the desired 

text (e.g., “m”) to the end of the line (e.g., “%6.3g m”). The “Scale” option in the “Label Properties” 

section can be used to change the displayed unit; e.g., setting this value to “100” changes the 

displayed number from m to cm. Line colour can be changed using the “Axis Colour” option in the 

“Axis Display Properties” dialogue in the “Properties” pane, and Font properties in the “Font 

Properties” section. Note that settings can be set to default using the “Save current settings values 

as default” icon on the right of the respective higher-ranked section heading (“Properties (Ruler1)” 

for position and length and “Display (RulerSourceRepresentation)” for formatting, respectively). 

 

Orthographic projection 

• In MeshLab, orthographic projection can be switched on and off by calling “View” > “Toggle 

Orthographic Camera” from the menu. The current setting is indicated in the “FOV:” entry in the 

“info” panel (“View” > “Show Info Panel”; appears at the bottom of the screen). 

• In ParaView, the respective setting is termed “Camera Parallel Projection” and can be found in the 

“Orientation Axes” section in the “Properties” pane. Note that activation of this option will only be 

valid for the current session; we therefore recommend to set it as default using the “Save current 

view settings as default” icon on the left of the “View (Render View)” section header. 

• In CloudCompare, click the “Set current view mode” icon (available in the left vertical toolbar), 

and select “Orthographic projection”. 
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Colour information 

• Vertex colours can be corrected in MeshLab for brightness and contrast using “Filters” > “Colour 

creation and processing” > “Vertex colour brightness contrast gamma”. 

 

Orthophoto generation 

• In MeshLab, the equivalent output can be generated by setting to “orthographic projection”, 

enabling the texture, disabling vertex colours (setting “Colour” to “Mesh”), and disabling shading 

(setting “Shading” to “None”; all options available in the “Layer Dialog” pane). 

• In ParaView, the texture has to be loaded, camera parallel projection enabled, and the model 

oriented in top view (see instructions above). To generate a pure orthophoto without oblique light 

shading, the “Light Kit” can be disabled in the “Light Inspector” pane (which can be activated in 

the “View” menu). 

 

Height maps (Paraview) 

• To produce a basic map, call the “Elevation” filter (“Filters” > “Alphabetical”). Note that the filter 

will only be available when the model is selected in the “Pipeline Browser”. After calling the filter, 

the z-axis needs to be selected as reference by pressing the “Z Axis” button in the “Properties” 

pane, and the map generated by pressing the “Apply” button. The line showing the direction of the 

filter should be hidden by unchecking the “Show Line” in the “Properties” pane. 

• Different colour scales can be selected by pressing the “Choose preset” button within the “Mapping 

Data” section of the “Colour Map Editor” pane. The latter can be activated by checking “View” > 

“Colour Map Editor”. To fill the lowest and/or highest parts of the model with uniform colour, the 

“rescale to custom range” option of the “Colour Map Editor” (second button of the vertical right-

hand button bar in the “Mapping Data” section) may be used. For example, values of 0.2 and 0.8 

will condense the colour scale to the middle 60% of the total height of the model. The colour 

distribution can furthermore be changed by adjusting the control points of the “Colour transfer 

function editor” of the colour Map Editor (horizontal colour bar in the “Mapping Data” section) to 

improve the visibility of details of interest. A colour scale can be inverted by pressing the “Invert 

the transfer functions” button in the “Mapping Data” section. 

• The colour legend will be shown by default, but can be toggled by pressing the “Toggle colour 

Legend Visibility” button available in the toolbar. Per default, the legend will only display relative 

values from 0 to 1 (corresponding to the lowest and highest elevations, respectively) rather than 

the actual total depth of the model in metres. The absolute model depth is indicated by the “Z 

range” delta value as seen in the “Bounds” section of the “Information” pane (“View” > 

“Information”). To change to an absolute scale in metre, this value can be copied to the second 

field of the “Scalar Range” option in the “Properties” Panel (available only when the “Elevation1” 

entry in the “Pipeline Browser” is activated). The plot and colour legend can then be updated by 

clicking “Apply” in the “Properties” pane, and clicking “Rescale to data range” (first button of the 

vertical toolbar in the “Mapping Data” section of the “Colour Map Editor”). The decimal place of the 

value entered in the “Scalar Range” field can be changed to achieve a scale in centimetres or 

millimetres instead of metres. 

• The lowest and highest values on the colour scale may be displayed in real number format by 

entering, “%-#6.2f” into the “Range Label Format” in the “Labels” section of the “Edit colour 

Legend Properties” (icon in the upper right corner of the “Colour Map Editor”). The option is 

available after toggling the advanced properties (gear icon in the upper right of the same dialogue). 
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The lowest and highest values can alternatively be disabled by unchecking “Add Range Labels” in 

the same section. 

• If the image is to be exported with a white background, the fonts of the colour legend can be 

changed from the default white to black. This is done using the “Edit colour Legend Properties” 

dialogue, which is available after clicking the icon of the same name in the upper right corner of 

the “Colour Map Editor”. In the dialogue, both the “Title Font Properties” and the “Text/Annotation 

Font Properties” need to be changed. 

• The elevation, direction, intensity and warmth of the light source responsible for the shading can 

be changed using the “Light Inspector” pane (“View” > “Light Inspector”). See section “Shaded 

reliefs” for more details. Disabling of the Light Kit disables any shading. 

 

Height maps (CloudCompare) 

In CloudCompare, height maps can be generated by adding a scalar field in Z-direction (“Edit” > 

“Scalar fields” > “Export coordinates to SF”; available when the mesh is selected). The colour map 

can then be activated by selecting “Toggle SF” from the context menu of the “Mesh” entry of the “DB 

Tree” pane. 

Various colour schemes are available in the “Colour Scale” section of the “Properties” pane (visible 

when the model is selected in the “DB Tree” pane), and can be edited using the “Colour Scale Editor” 

(the gear icon in the “Colour Scale” section). The default scheme, the four-colour 

“Blue>Green>Yellow>Red”, works well for most ichnological objects, as it provides sufficient, but not 

excessive, colour diversity. As in ParaView, the colour range can be edited to fill very high or low parts 

of the model that are not of interest with uniform colour; this can be achieved by changing the 

“saturation” values in the “SF display params” section of the “Properties” pane. 

A colour legend can be added by checking the “Visible” checkbox in the “Colour Scale” section of the 

“Properties” pane. In contrast to ParaView, the colour legend will display absolute rather than relative 

values. 

The position of the light source can be changed interactively by simultaneously pressing Ctrl and the 

right mouse button. 

 

Contour plots (Paraview) 

• Call the “Contour” function (“Filters” > “Common”), which is available after application of the 

“Elevation” function and selection of the “Elevation1” entry in the “Pipeline Browser”. 

• Make sure that “Contour1” is selected in the “Pipeline Browser”. Remove pre-defined contours by 

clicking the “Remove all entries” icon in the “Isosurfaces” section of the “Properties” pane. 

• Enter the desired number of contours in the “Number of Samples” field of the “Generate Number 

Series” dialogue, which is available after clicking the “Add a range of values” button in the 

“Isosurfaces” section of the “Properties” pane. 

• For relative contours: Note that the first and last entry in the value range (the minimum and 

maximum height, respectively) will not be plotted; 7 steps will therefore result in 5 contours 

displayed. 

• Absolute contours are available after the “Scalar Range” of the “Properties” pane of the “Elevation” 

filter was set according to the total height of the model, as explained above under “Height maps 

(ParaView)”. For absolute contours, the left field in the “Range” section in the “Generate Number 
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Series” dialogue should be set to the desired distance between contours, and the value displayed 

in the right field should be rounded down to a next multiple of that distance. The required number 

of contours needs to be calculated (value of the left field/value of the right field) and entered in 

the “Number of Samples” field. For example, if the total height of the model is 0.068 m, and the 

desired distance between contours is 0.01 m, then the left field should be “0.01”, the right field 

“0.06”, and the “Number of Samples” field “6”. 

• The contours can then be generated by clicking “Apply” in the “Properties” pane. Per default, the 

contours are coloured according to the colour scale selected in the “Elevation” filter. To change to 

a solid colour, select “Solid colour” in the first drop-down menu of the “Colouring” section of the 

“Properties” pane. The desired colour can then be picked by clicking the “Edit” field in that same 

section. Best results when exporting at high resolution can be achieved by selecting “Points” in the 

“Representation” drop- down menu, which can be found in the section “Point Locator” in the 

“Properties” pane. Thickness of contours can be changed using the “Line Width” (when 

“Representation” is set to “Surface”) and “Point Size” (when “Representation” is set to “Points”); 

both are available in the “Styling” section of the “Properties” pane with advanced options enabled. 

• A contour plot may be combined with other layers of the “Pipeline browser” (e.g., a height map) 

by setting the respective entries in the “Pipeline browser” to visible. It is possible to combine two 

types of contours in the same plot (e.g., formatting each fifth contour with a greater width and 

different colour) by applying a second contour plot. 

 

Contour plots (CloudCompare) 

• The “Rasterize” tool of CloudCompare does not work on meshes but on point clouds; therefore, 

the vertex points of the model need to be selected as input (the “Vertices” entry in the “DB Tree”, 

which is hidden by default and appears when clicking on the arrow before the “Mesh” entry). Now, 

the tool can be started from the menu (“Tools” > “Projection”). In the “Rasterize” dialogue, the 

“Fill with” option of the “Empty cells” section should be set to “interpolate”, and the grid generated 

by pressing the “Update grid” button. 

• After the grid was created, absolute contours can be created using the “Contour plot” tap of the 

“Rasterize” dialogue. Four parameters may be changed: The “Start value” defines the level of the 

first contour (in metres; this value may be set to “0”). The “Step” value defines the distance 

between contours (in metres). The “Min. vertex count” allows for filtering very short contours (e.g., 

with a value of 50, all contours of less than 50 vertex points will not be displayed). The “Line width” 

specifies the width of the individual contours, and frequently needs to be increased especially if 

images of higher resolution need to be exported. If the “Colourize” option is checked, the separate 

contours are coloured according to their height using the active colour scale. The contour plot is 

generated, and a preview displayed, after pressing the “Generate” button. If correct, the contours 

need to be exported by pressing the “Export” button. The exported contours will be stored within 

a new entry in the “DB Tree”, and can be combined with other entries, such as height maps. 

• The contour colour can be changed (e.g., to “black”) by calling “Display” > “Display options” and, 

in the “Colours and Materials” section, changing the colour of the “Points” entry. 

 

Shaded reliefs 

• In MeshLab’s “Layer dialog”, activate the tab for solid model rendering (the blue cylinder icon). In 

this tab, “Shading” can be set to “Face”; “Colour” set to “Mesh”; “Back-Face” set to “Single”; and 

“Texture Coord” to “off”. Setting “Shading” to “Vert” instead of “Face” is possible as well and will 
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lead to a more smoothened surface with more indistinct polygon boundaries; if any black spots 

are visible on the mesh surface, these can be resolved by applying “Filters” > “Cleaning and 

Repairing” > “Snap Mismatched Borders”. The position of the light source can be changed 

interactively by pressing Ctrl+Shift and dragging with the mouse over the model. 

• In ParaView, the position of the light source has to be entered using the “Light Inspector” pane (to 

be activated by checking “View” > “Light Inspector”). If a texture or height map was already 

applied, they should be disabled beforehand (setting “Texture” to “None” in the “Properties” pane, 

and deactivating the Elevation entry in the “Pipeline Browser”, respectively). Also, colouring should 

be changed to “Solid colour” in the “Colouring” section of the “Properties” pane. Within the “Light 

Inspector”, the default “Light Kit” should be disabled, and a new light source added (“Add Light”). 

Important parameters are the “Intensity” and “Light Position” values. For example, an intensity of 

“2” and a position of “-1”, “1”, and “0.2” (along the x, y, and z-axis, respectively) will produce 

low-angled light from the upper left and works well with surfaces of relatively low relief. For 

surfaces with higher relief, the z value (the height of the light source) can be increased. 

• In ParaView, the position of both the light source and focal point can be changed interactively. 

After following the steps described above, a white line can be seen extending from the centre of 

the model, provided that the model was centred on the origin of the coordinate system, as 

described above. This line connects the focal point (at the centre of the model) to the light source 

(a white circle; zoom out if not seen). The light source can be dragged around the model with the 

mouse; decreasing its distance to the model will increase intensity. 

• In CloudCompare, the light source can be changed interactively by pressing Ctrl+right click. 

 

Surface inclination plots (ParaView) 

• To produce a surface inclination plot, the vertex normals have to be stored within the model file. 

This can be achieved when exporting the model in MeshLab by activating the “Normal” option in 

the “Choose Saving Options” dialogue that will appear when attempting to save a model in 

MeshLab. Furthermore, it may be necessary to apply “Filters” > “Cleaning and Repairing” > “Snap 

Mismatched Borders” in MeshLab to avoid artefacts in the form of black spots on the image output. 

• Select “Normals” in the first drop-down menu of the “Colouring” section of the “Properties” pane. 

Select “Z” in the second drop-down menu. In the “Colour Map Editor”, select the “X Ray” preset 

using the “Choose preset” button, and invert the colour scale using the “Invert the transfer 

functions” button. Restrict the range of the colour map using the “Rescale to custom range” button. 

Models with very low relief require a more severe restriction (e.g., 0.95–1) than models with higher 

relief (e.g., 0.6–1). For a pure inclination plot without additional shading, disable the “Light Kit” 

using the “Light Inspector” pane. 

• For directional plots equivalent to a shaded relief, choose “X” or “Y” instead of “Z” in the “Colouring” 

section. Restrict the colour scale (e.g., -0.2–1) to reach the desired output. 

 

Ambient occlusion plots (MeshLab) 

• Apply the “Ambient occlusion” filter (available in “Filters” > “Colour Creation and Processing”), 

and, in case the model includes a texture, set “Texture Coord” to “Off” in the “Layer dialogue”. 

• Ambient occlusion plots calculated by MeshLab tend to be overexposed. This can be corrected 

using the “Vertex colour Level Adjustment” filter (available in “Filters” > “Colour Creation and 
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Processing”), where the “Gamma” and “Max output level” values need to be lowered appropriately 

(use the “Preview” option provided by the filter for a live preview). 

 

Ambient occlusion plots (CloudCompare) 

Apply the Ambient Occlusion filter via either the “P.C.V.” icon from the top menu bar or from “Plugins” 

> “P.C.V. (Ambient Occlusion)”, using the default “ShadeVis” settings. In the Properties menu panel, 

uncheck “Materials/textures”. 

Ambient occlusions tend to be overexposed to a lesser degree when compared with Meshlab. After 

saving the image in CloudCompare (“Display” > “Render to file”), the overexposure be corrected in 

image editors (e.g., GIMP) by adjusting the “Levels” or “Brightness/Contrast”. 

 

Radiance Scaling (Gratin) 

• In Gratin, open the pipeline file "radiance-scaling-gratin-pipeline.gra" provided in the 

supplementary information of the present paper using "File" > "Open". The pipeline of nodes will 

appear in the lower pane of the program; zoom in and out with the mouse wheel and right click + 

drag with the mouse to scroll. 

• To load an OBJ model, double-click into the leftmost node of the pipeline ("genericObjLoader"), 

click "Load" in the "Node parameters" pane to select the model, and press "Reset cam". Three 

graphical outputs applying radiance scaling with different settings can be found on the far right of 

the pipeline (labeled "enhancedShading"). The outputs can be displayed in the "View/Interact" 

pane by double-clicking into them and pressing the "space" key. 

• The strength of the filter can be changed using the "gamma" parameter in the "Node parameters" 

of the respective node. The size of the features that are to be enhanced is determined by the 

"sigmaS" parameter, which can be changed in the respective previous node (labeled "bilateral 

Filter") after double-clicking into them. The resolution of the image to be export can be increased 

in the Settings of the "genericObjLoader" node (increase "W+" and "H+"). 

• The image that is loaded into the "View/Interact" pane can then be exported with "Tools" > "Export 

node output". 

 

Cross sections (CloudCompare) 

• The point cloud of the mesh needs to be selected (the “Vertices” entry in the “DB Tree”, available 

after clicking on the black arrow), and all three levels in the DB Tree including the Mesh and 

Vertices activated. Then, the segmentation feature is to be called (“Tools” > “Segmentation” > 

“Extract Sections / Unfold”), which allows to draw the line by mouse clicking (a left click will add 

section points, a right click will finish the defined line). After the line was defined, the “polyline 

edition” mode needs to be disabled by clicking the “Create polyline by clicking on the screen” tool 

(the first entry in the toolbar that appeared on the upper right of the model window). The section 

can now be exported using the “Extract points along active sections” tool of the same toolbar. The 

extracted profile is automatically added to the “DB Tree”, and the tool can be closed using the 

green tick icon. 

• Before data export, the profile needs to be rotated so that the view is exactly vertical to the line. 

This rotation can be applied to the “Section contour” (which needs to be selected in the DB Tree) 
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using the “Fit Plane” and “Apply transformation” functions. After rotation, the line can be centred 

on the display by selecting it in the “DB Tree” and pressing Z. 

• Coordinates of the cross-section line can be exported by selecting the “vertices” within the 

“Extracted profiles” entry of the DB Tree, followed by applying “File” > “Save”. 

 

Measurements on 2D visualisations (Inkscape) 

• Before measuring, the measurement tool should be set to centimetres and the scale factor in 

percent specified in the “Scale %” box (the value can be calculated by measuring a scale on the 

image, ideally the “Axes Grid” drawn by ParaView). 

• Measurements can then be done with the “Measurement” tool, available from the toolbar or by 

pressing the “M” key. Measurements are done by left-clicking and dragging. 

• Measurements can be saved to the document for future reference using the “Mark Dimension” 

function, preferably on a new layer. 

• Angles can be measured by left click and drag, which measures an arbitrary line against a 

horizontal line; the latter can be changed by hitting the shift key. 

 

Tracings and image stacks (Inkscape) 

• Tracings can be done point-by-point using the “Draw Bezier curves and straight lines” tool. 

Smoothing of the completed tracing can be done by selecting the path, pressing F2 to allow for 

node editing, selecting all nodes of the path, and applying the “Make selected nodes smooth” 

function available in the main toolbar. 

• Alternatively, tracings can be done by dragging the mouse using the “Draw freehand lines” tool. 

Increase the “Smoothing” parameter in the main toolbar to create less jagged tracings. 

• A precise overlay of multiple visualisations can be most easily produced when all images have been 

exported using the same application, such as ParaView. 

• To produce the image stack, the imported images should be scaled proportionally to the same 

width (or height) using the “Transform” function, and centred on both the horizontal and vertical 

axis using the “Align and Distribute” tool. 

 

Trackway calculator (Inkscape and LibreOffice Calc) 

• To allow for coordinate export in Inkscape, the “Export xy” plugin (provided in the supplementary 

information) needs to be installed. The two files “ExportXY.inx” and “ExportXY.py” need to be 

placed into the folder “extensions” within the Inkscape program directory, and Inkscape restarted. 

The plugin will then be available by calling “Extensions” -> “Export” -> “Export xy” from the 

Inkscape menu bar. 

• Before coordinate export, it has to be ascertained that the document scale is set to “1” (the “Scale 

x:” field in the “Page” pane of the “Document Properties”, which is available from the “File” menu). 

• Coordinates are placed in Inkscape using the “Draw Bezier curves and straight lines” tool. After 

the “Z” coordinate has been placed on the first footprint (e.g., LP1, the first left pes impression), 

the “L1” coordinate of the next footprint (e.g., LM1, the first left manus impression) is placed, and 

so on, resulting in a connected sequence of straight lines capturing the whole trackway. 
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• To improve the accuracy in fitting the footprint axes, centres, and perpendicular lines, grid 

templates may be placed over each footprint prior drawing of the lines. These templates, which 

are provided in the example Inkscape file in the supplementary information, can be easily scaled 

and rotated to fit the respective footprint. 

• If one or several coordinates cannot be placed due to incomplete or missing footprints, placeholder 

coordinates have to be placed to the right of the trackway figure of the sheet (e.g., an entirely 

missing footprint requires five placeholder coordinates). These placeholder coordinates need to 

have a x coordinate greater than a number to be specified in the “Trackway calculator” form 

(“Ignore coords with x greater as:”). 

• The output of the “ExportXY” plugin may than be copied and pasted into the third and fourth 

columns of the first sheet of the “Trackway calculator”. 

• After all data is entered, the document should be recalculated by pressing “F9”. 

 

 

 

 

 


	22 Lallensack et al 2022 Ms
	22 Lallensack et al 2022 Appendix

